Welcome to OpenFX Online Help

Introdução ao programa 3D OFX

Bem vindo ao sistema de ajuda.


How to Use This Function Reference

Como usar esse manual de referência rápida

Esse manual tem como objetico dar uma referência do trabalho no OFX a novatos e experientes usuários. Para encontrar a função procurada, note o menu onde algumas opções aparecem, e procure nos sub-menus o conteúdo.

Todas as funções são listadas em ordem do menu, da esquerda para a direita e do alto para baixo. O layout geral, ícones e ferramentas são listados no início da seção de cada módulo, depois dos menus.


Introduction to 3D

Introdução ao 3D

O mundo em que vivemos é 3D. Infelizmente os monitores dos computadores ainda são bidimensionais, o que provoca uma certa dificuldade em entender e manipular um software 3D. Mas a sensação tridimensional, ainda que limitada, pode ser sentida numa tela 2D.

As telas dos computadores são formadas de "pixels", pontos que formam as imagens no monitor. Quanto maior o número de pixels maior a resolução da tela do monitor.

Os programas de arte bidimensional, animação e CAD usualmente usam um cursor (em forma de seta) que efetua uma operação no lugar especificado na tela, especificando um lugar na tela e é controlado pelo mouse ou outro dispositivo como uma "tablet", por exemplo.

No 3D nós precisamos de um cursor adicionalr. Visto que a tela não possui profundidade, esse cursor extra nos ajudará a simular a profundidade.

Sendo assim, nos projetamos o software 3D de forma a apresentar todas as principais vistas na mesma tela.

Assim vc poderá trabalhar em todas as vistas usando usando recursos 2D para simular operações em 3D.


OpenFX Metaphor

Animação e modelagem

O principal conceito do programa é observar as convenções padrões de:

  • Clique num item para selecioná-lo.
  • Duplo clique para informações adicionais.
  • Clique e arraste para movê-lo.

Essas ações são efetuadas nas vistas. Um Cursor3D pode ser colocado em qualquer lugar do espaço virtual movendo-o em uma ou mais vistas.

Os módulos Animador e Designer possuem componentes principais, ferrametas e ações. Ferramentas são para uso contínuo e ações são aplicadas uma de cada vez. Quando uma ferramenta é ativada, ela permanece ativa até outra ser selecionada.

A linguagem do Animador e do Modelador (Designer)

Nós usamos um modelo de faces triangulares para animar.

Objetos podem ser qualquer coisa.

As faces triangulares são unidas para formar superfícies de modelos e quanto maior o número de faces, mais realístico será o objeto modeladoa.

As faces possuem atributos adicionais como cores, texturas e mapeamentos (imagens aplicadas nas superfícies como pinturas).

As faces são posicionadas usando um vértice em cada canto, e cada face é cercada por três arestas .

Vc usa o mouse para mover os vértices para alterar a forma do modelo. Há várias ferramenta para ajudá-lo.

As ações ocorrem dentro de um número de quadros , um filme normalmente exibe 24 quadros por segundo, um desenho animado tradicional 12.

Um controlador chamado Q-chave especifica o avatar, posição, tamanho e rotação nos quadros-chaves .

Animações são representadas em "malha" no Animador e renderizadas num processo relativamente lento com total cores, sombras, reflexos e efeitos, quadro a quadro. Unidos depois para formar um filme.

No animador o termo "Ator " é usado para descrever cada elemento. Há vários tipos de atores, inclusive as câmeras são denominadas atores.

O ator possui um avatar (personificação, algo como que o personagem que o ator está representando) que nada mais é do que o modelo criado no Designer. Atores podem mudar de avatar durante uma animação.


3D Views of Objects

Visualização 3D dos objetos

Imagine-se olhando na frente de um aquário, sim, há um peixe lá dentro. Ele não pode se mexer pois o tamanho do aquário é igual a suas dimensões. Agora imagine-se olhando a parte exatamente frontal ao aquário. Depois olhando de cima, em seguida olhando de lado e por fim olhando de meio perfil. Bem, é assim que um programa 3D representa um objeto 3D para vc, usando essas vistas.

O princípio básico é tentar aproximar a modelagem 3D ao desenho realizado no papel. A princípio vc pode ter dificuldades de entender o processo, mas com o tempo e prática ele será mais natural e fácil.

Modelos 3D de objetos


3D Models of Objects

Modelos 3D de objetos

Como já explanado, para termos uma face, que representará uma superfície precisamos de 3 vértices ligados por arestas formando um triângulo.

Cada vértice pode ter coordenadas diferentes no espaço 3D. Agora imagine vários triângulos ligados entre si formando uma superfície que lembra um peixe. E assim que os objetos são representados, por conjuntos de triângulos, ou faces.

Suponha que vc precise de um cubo, 12 triângulos serão suficientes para formar um cubo perfeito como mostra a figura abaixo.

Mas, e se eu quiser representar uma esfera? O princípio é o mesmo, e quanto maior o número de faces mais suave e perfeito será uma representação curva. E isso vale para modelagens de objetos orgânicos.

Vc deve procurar um ponto de equilíbrio quando modelar visto que quanto mais faces possuir maior o tempo de renderização e memória consumida vc terá.


Painting for Realism

Realismo

Além do número de faces no modelo, o passo mais importante para dar um toque de realismo a um modelo é preparar a aparência da superfície do mesmo, que pode ser uma simples cor ou uma complexa imagem ou textura. O impacto que um bom mapeamento pode provocar dependerá do seu talento em "pintar" um objeto 3D da melhor forma possível. Mas lembre-se, a exemplo do número alto de faces, quanto maior o mapeamento maior o tempo de renderização e memória consumida. Novamente o estudo antecipado é muito útil.


Terms used in OpenFX

Termos e definições

Cursor3D - Um programa bidimensional possui um único cursor, mas quando trabalhamos no espaço 3D precisamos de um cursor adicional que possa trabalhar nas três dimensões espaciais. Ele pode ser colocado em qualquer lugar do espaço 3D com o ponteiro do mouse.

Ator - Um ator é o termo usado para cada elemento na animação. Um ator possui um Avatar (personificação), o avatar é mutável na animação o ator é constante. Há 12 tipes de atores. O mais importante é o tipo modelo. Uma ator modelo usa um avatar que é um modelo criado no Designer. Para entender isso imagine uma aeronave voando sobre uma cidade seguindo um caminho pré-definido, a aeronave é o ator modelo usando uma avatar de um caça F15, imagine que na verdade deveria ser um F117 na animação, para acertar basta apenas trocar o avatar do ator modelo aeronave por uma avatar de um modelo de F117. Modelos são gravados com a extensão de arquivo .MFX.

Trilha do ator- É o caminho que o ator seguirá durante a animação. Uma trilha somente será visível se houver duas linhas do tempo de movimento que sejam contíguas.

Janela ativa - É a vista que está atualmente em foco. Ela é iluminada por um contorno amarelo. Pressione Tab para caminhar pelas vistas, clique com o mouse numa vista para torna-lá ativa.

Ponto pivô - Cada modelo tem um ponto usado no animador para manipular o modelo. Por exemplo se um modelo for uma aeronve seguindo um caminho o ponto do modelo que exatamente segue o caminho é o ponto pivô.

Linha do Tempo - Para direcionar a atividade de um ator na animação é requerido o uso de 4 linhas do tempo, avatar, posição, rotação e tamanho. Uma linha do tempo expande um número de quadros e possui um quadro-chave associado a eles. O quadro-chave é o quadro onde a ação do ator é exatamente especificada, enquanto que nos outros quadros intermediários o programa calcula sozinho baseado na interpolação dos valores.

O quadro-chave sempre será o último quadro na linha do tempo. Uma linha do tempo é o intervalo de quadros onde o ator efetua as ações determinadas pelo quadro-chave.

Linha do tempo expandida - É o quadro atual se ele na linha do tempo é menor igual ao quadro atual e se o último quadro na linha do tempo é maior ou igual ao quadro atual.

Avatar - Para ser visível na animação um Ator precisa possuir um avatar. O tipo de ator dita que sorte de avatar ele pode possuir, mas atores podem mudar de avatar durante a animação.

Quadro atual - É o quadro na animação que é exibido na vista e onde qualquer mudança pode ser feita.

Curva - Um conjunto de vértices concectados por arestas sem formar nenhuma face. Curvas podem ser abertas ou fechadas.

Aresta - Um seguimento de reta conectando dois vértices.

Face - Uma superfície triangular definida por 3 arestas unidas exatamente por 3 vértices .

Ponto perseguidor - Uma localização (Especificada no Designer) no modelo onde outro objetos podem seguir.

Quadro - Igual a convenção cinematográfica de quadros para cinema e animação. Pode ter imagens em seguência na proporção por exemplo de 24 quadros por segundo. Cada quadro é composto de uma imagem.

Matiz Plástico - Um algorítimo de renderização que sombrea o modelo misturando e desfocando superfícies adjacentes. É usado pela vista OpenGL.

Mapeamento imagem - Um mapeamento imagem é um arquivo GIF ou TGA que será usado para "pintar" faces do modelo adicionando decalques detalhados na superfície.

Indicado - Para escolher um particular vértice, aresta, face, ou objeto para ser afetado por uma operação sem seleciona-lo coloque o Cursor3D sobre ou próximo a ele (entre um ou dois "pixels") para ser indicado. se mais de um elemento está indicado então o mais próximo do cursor3D será usado.

Quadro-chave - Um quadro chave é o quadro onde algumas informações são especificadas sobre a atividade do ator. O conceito é igual ao dos desenhos animados onde o desenhista mestre determina as partes importantes da animação e os desenhistas de produção fazem os quadros intermediários, aqui no caso feito pelo programa.

Q-chave - É a barra inferior do Animador onde é exibida as linhas do tempo (avatar, posição, rotação e tamanho) do ator atual. Onde vc pode inserir e modificar os quadros-chaves da animação.

Modelo - É unidade principal da estrutura. Um modelo é feito por faces e cada face é determinada por três arestas. O tamanho, posição e orientação da face é determinada pelos vértices que a definem.

Chaves de modificadores - O Shift, Ctrl e Alt são usados para modificar a ação das ferramentas do Designer. Se um ou outro é usado então a ferramenta é modificada apropriadamente.

Morfose - Proporciona que um modelo se transforme em outro.

Nó - Um nó é um ponto em um caminho ou robô que pode ser manipulado. E representado por um pequeno quadrado.

Origem - A origem padrão são as coordenadas de valores (0, 0, 0).

Caminho - Uma Curva que é usada no Animador como caminho para os atores seguirem (.PTH). E pode ser usado no Designer para definir uma extrusão.

Matiz esmalte - Um algorítimo de renderização que sombrea um modelo suavizando e descreve superfícies, texturas e propriedades de reflexão e pode simular espelhos. O Render usa essa matiz como padrão se o raytrace não estiver ativo.

Suavizar - Esse é um procedimento que ajuda a remover a aparência facetada da superfície de um modelo.

RayTrace - Um complexo sistema de renderização capaz de criar efeitos espelho, transparências, sombras, e refrações.

Status da Seleção - Cada vértice no modelo pode ter um desses estados: Selecionado, Deselecionado, Oculto. Selecionado vértices são manipulados pelas ferramentas e ações. Deselecionado Vértices não são afetados pelas ferramentas ou ações. Oculto vértices não são exibidos e não são afetados.

Textura - Uma textura é um algorítimo que pode adicionar finos detalhes a superfície do modelo. Exemplos são madeira e Mármores. Eles não dependem de uma imagem pois são gerados matematicamente.

Esqueleto - O esqueleto e os nomes hierárquicos são a mesma coisa. O esqueleto é um termo usado para facilitar a compreensão do sistema de vértices que podem deformar partes de um modelo.

Ligação do esqueleto- O esqueleto é formado por um número de ligações, cada ligação tem um Osso associado e um nó no seu fim. Cada osso é amarrado a outra articulação no nó ou "raiz".

Intensidade de brilho - O polimento de uma superfície é simulado pela intensidade de brilho. Basicamente quanto mais polida uma superfície maior será a intensidade de brilho que ela possuirá.

Vértice - Um ponto distinto no espaço 3D representado por um ponto amarelo ou vermelho se selecionado ou deselecionado respectivamente.


OpenFX Modules

Módulos do programa

Há 3 módulos no OFX:

Animator onde vc produz a animação propriamente dita.

Designer onde vc modela seu objetos.

Renderer usado para renderizar o trabalho final.

Além de outros programas externos de múltiplas finalidades chamados extensões.


Animator

Animador

Exibe o módulo Animador.

O módulo Designer não é fechado e os modelos continuam na RAM.


Objects

Atores (Algumas programas de animações os chama de objetos)

Existem 12 tipos de atores no módulo de animação. Cada ator é representado por um ícone. A Câmera, Luz e Alvo possuem ícones facilmente identificaveis na vista. Os atores Modelo, Morfose, e Robô são representados como cubos limitados, malha ou contorno. Os atores Atmosfera, Efeito de imagem e Diretor não possuem representação, ator CSG é sempre representado por um cubo limitado e o Solo é representado com um ponto, retângulo, ou linha.O Ator Caminho é representado por um segmento de linhas conectadas ou não com nós quadrados.

Nos três primeiros, Modelo, Morfose, e Robô serã visíveis na animação renderizada se eles usarem um Avatar (personificação) e estiverem em frente a câmera no quadro atual. Os Avatars são projetados e desenhados no Designer e que Avatar o ator está usando é especificado na linha do tempo Avatar do ator.

O próximo grupo, Atmosfera, Solo e CSG poderá ser visível sob as mesmas condições mas seus Avatars são muito mais simples para especificar e isso é feito exclusivamente no Animador.

Quando um linha do tempo do Avatar do ator é criada, é colocada no Q-chave ou ou diretamente adicionado no ator, o Animador apresenta uma caixa de diálogo apropriada para especificar coisas como Cor da Atmosfera, Textura do Solo, etc.

Os Efeitos de Imagem são um tipo especial de ator que é aplicado como um pós-processo na renderização final da animação. Eles não são visíveis na janelas das vistas.

Os tipos de atores restantes, Câmera, Luz, Caminho, Diretor e Alvo não são visíveis em renderizações mas são muito importantes na produção da mesma.

Modelo
Esse tipo de atou usa um Avatar que é o modelo desenhado no Designer. Um Ator Modelo pode usar um Avatar na animação, onde ele é especificado na linha do tempo relativa. Qualquer mudança do avatar altera a linha do tempo. Se um ator mudar seu avatar, e ambos forem compatíveis, o ator será instruido para morfosear gradualmente para o outro.

Morfose
O ator Morfose usa um avatar desenhado no Designer, mas 2 ou mais modelos podem ser especificados juntos para a morfose. Um conjunto de modelos são manipulados com uma simples entidade. Eles são muito práticos quando for necessário usar uma sequência de várias morfoses na animação.

Câmera
Ator Câmera provê os 'olhos' que verão a ação. Pelo menos uma câmera deve haver, outras podem existir mas uma de cada vez é apresentada na vista câmera.

Alvo
Alvos são usados como um ponto para apontar a câmera e definir ações que precisam ocorrer no mesmo lugar em tempos diferentes.

Luz
O Ator Luz provê iluminação para a animação, se múltiplas luzes estão presentes então é uma boa idéia escurecer algumas. Luzes podem lançar sombras sem adicionar nenhuma iluminação ou vice-versa. Luzes spots possuem um cone que lança sombras fotorealísticas.

Caminho
Um ator caminho é usado por outros atores para movimentar relativo a ele. A velocidade de cada ator movendo no caminho é definido pela Velocidade . Caminhos podem ser abertos, fechados or lidos a partir de um arquivo PTH. Caminhos não são visíveis na renderização.

Atmosfera
Um Ator Atmosfera se forma no fundo da animação. Somente um ator Atmosfera é permitido por animação.

Solo
Um plano Solo é uma superfície sólida horizontal que e extendida ao infinito em todas a direções. Pode possuir multiplos avatares, texturas e imagens aplicadas mas somente um ator desse tipo é permitido. Nas vistas ele é representado como uma linha horizontal. Um retângulo representa o solo na vista superior, e pode ser movido, rotacionado ou escalonado na linha do tempo apropriada.

Efeito de pós-processo
Modifica uma cena previamente renderizada. Exemplos de efeitos são Reflexos de lentes, Efeitos especiais de video, Neblina, etc.

Robô
O Ator Robô usa um modelo que possui um esqueleto. O esqueleto pode ser manipulado no linha do tempo do avatar. O esqueleto movimentado distorce o avatar do modelo para representar uma animação. Se o Ator está selecionado a ferramenta selecionador de vértices pode ser usado para selecionar as ligações do esqueleto do ator.

CSG
CSG Ator representa algumas geometrias básicas que possuem superfícies curvas que requerem um número muito grande de faces para uma renderização mais suave.CSG pode ter esferas, discos, cilindros, ou tubos como avatares. Nota: Atores CSG não podem lançar sombras ou aparecerem em reflexosmes. A first order subtractive intersection can be arranged between solid CSG's. Note: CSG Actors do not cast shadows or appear in reflections.

Diretor
O Ator diretor é usado para especificar qual câmera ésta ativa. Na linha do tempo do Diretor a câmera padrão está ativa. Somente um diretor pode existir em cada animação. Cada linha do tempo do Diretor indica uma câmera: Para trocar a câmera e quando ela estará ativa na animação, escolha na Q-chave a câmera que deseja usar.


Templates

Modelos

Há alguns modelos de animação que rapidamente podem ajudá-lo a montar uma animação instântanea.

Esses modelos exemplos podem ser facilmente editados e se encontram no menu arquivos.


Keyframer

Q-chave

O Q-chave é um módulo interno que controla as linhas do tempo e quadros chaves de todos os Atores que podem ser visualizados e editados.

O módulo é exibido através do menu Visualizar > Exibir Q-chave ou pressionando a tecla K. Pode também ser mostrado como uma janela acessando o menu Visualizar > Q-chave flutuante/docado ou pressionando Crtl K.


Object Orientated Tools

Ferramentas de orientação dos objetos

Dependem do tipo de Ator onde são aplicadas.

O selecionador de vértices por exemplo, atua da mesma forma como o selecionador de ator na câmera o no ator modelo, mas move vértices individuais em caminhos, e em pontos pivô de robôs.


Selecting Objects

Selecionando atores

Para selecionar um Ator , clique na ferramenta selecionador de ator.

Caminhos e robôs possuem pontos de seleção. Câmera, Luz e alvo são selecionados clicando em seus ícones. Outros atores clicando em seus contornos.

O menu Editar > Selecionar ator possue uma caixa de diálogo com uma forma simples de selecionar um ator pelo nome.


Quick Render

Renderização rápida

Renderiza com mapeamento, texturas, reflexões, etc e anti-serrilhado médio. F12 (ótimo para previsualizações rápidas).

Dica: Renderização rápida é muito mais veloz em monitores com 16 milhões de cores.


Animator

Designer

Exibe o módulo Designer.


Vertices, Edges, and Faces

Vértices, arestas, e faces

Os modelos são criados por conjuntos de faces feitas com 3 vértices ligados por arestas.

Criação

Utiliza-se as ferramentas Caneta e lápis para modelar um objeto.

Experimente essas ferramentas importantes!


Face and Edge Creation

Criação de aresta e face

O tema central do sistema de modelagem baseada em triângulos é o facetamento.

O contorno não preenchido na esq. não será renderizado um vez que não é composto de faces (triângulos) e será considerado um buraco. O contorno preenchido a direita será renderizado como uma superfície.

Existe 2 caminhos para facetar (Criar faces triangulares que definem preenchimento) um contorno ...

Auto Preenchimento | Usando as ações Preencher contorno ou Preencher no cursor
Tecer | Usando a ferramenta Caneta


Auto Filling

Auto Preenchimento

Cria faces (Facetadas) para preencher um espaço cercado por vértices selecionados usando os comandos Ações> Preencher contorno ou Ações> Preencher no Cursor

Auto preenchimento é de longe a forma mais simples para facetar um objeto, mas nem sempre é apropriado. Para usá-lo, desenhe um contorno com a Caneta , lembrando de fecha-la, (A Caneta poderá fechar a curva se vc clicar exatamente em cima do primeiro vértice criado). Então, com todos os vértices da curva selecionados, centralize o Cursor3D e escolha Preencher no Cursor no menu Ações. A curva será mostrada agora como um sólido. Vc pode observar isso tornando ativa a vista OpenGL. A vista OpenGL somente exibe faces preenchidas.

Auto preenchimento tem suas limitações. A principal limitação é que somente formas convexas podem ser facetadas. É possível facetar uma forma côncova, mas tenha cuidado onde for colocar o cursor 3D.


Strutting

Modelando

Vamos entender o processo de modelagem usando a ferramenta Caneta ou o Lápis.

Desenhe uma curva como a apresentada abaixo usando a caneta.

Desenhe uma aresta entre os vértices 6 e 1 para fechar a curva. Clique exatamente sobre o vértice 1, caso contrário um novo vértice será adicionado e a curva não será fechada.

Com a curva da figura 1 criada, dê uma olhada na vista Câmera. A vista OpenGL não ira mostrar nada até que a curva seja facetada. Note que a opção cobertura de malha da vista OpenGL está desligada.

Crie uma aresta entre o vértice 2 e 6 com mostra abaixo. Com a caneta ativa, clique no vértice 2 e então no vértice 6.

Assim uma face será criada e será visível na vista OpenGL. Agora crie mais duas arestas para formar as faces desejadas como mostra a figura 3.

Depois disso, vc verá um sólido 3d na vista OpenGL.

Agora tentaremos um contorno mais complexo.

Desenhe uma letra "C" com apresentado abaixo.

Note que a situação é igual a anterior, vc tem um contorno não facetado, crie igual ao exemplo anterior as arestas que formarão faces seguindo o esquema abaixo.

A aresta marcada em vermelho é importante. Ela representa uma mudança no rítmo. Veja que a sequência da construção segue uma regra geométrica mas na aresta vermelha a sequência é quebrada. Note que o ângulo formado pelas arestas 12-11 e 12-7 é maior que 90 graus. A melhor escolha é manter o ângulo menor que 90 graus para evitar faces muito grandes.

Regra 1: sempre evitar faces grandes e compridas.

Não é uma proibição a princípio, o objetivo dessa regra é facilitar a manipulação de objetos posteriormente.

Regra 2: Nunca, nunca tenha faces sobre outras.

A Figura 10 demonstra com o que quatro faces sobrepostas aparecerão. Nunca desenhe uma aresta passando por cima de outra.

A Figure 11 mostra a maneira correta e perfeita para fazer o mesmo arranjo.

A Figure 12 mostra como uma simples aresta pode criar o mesmo arranjo da figura anterior.

Claro que o Render vai eliminar qualquer problema da figura 10 na imagem final, mas é um estilo muito ruim de criar objetos. Vc sentirá isso quando tiver que fazer uma modificação no modelo ou uma morfose.

E lembre-se, quanto mais faces usar mais memória irá gastar.

Finalmente, como fazer buracos.

Toda face que possuir mais que 3 vértices é vazada. Portanto numa face triangular com a demonstrada abaixo no interior do "A", basta criar uma aresta extra do centro para a extremidade fazendo com que o triangulo interno possua 4 vértices tornando-se assim um buraco.

Veja a próxima demonstração de como criar uma forma válida com um buraco no centro para uma extrusão.

Crie as arestas para formar as faces.

Note que o centro possui cinco vértices não ligados por arestas formando assim um buraco. Quando vc extrudir essa forma ela se parecerá um tubo.


Phong Smoothing

Suavização

Esse é um procedimento que remove a aparência facetada de superfícies curvas de modelos.

O diagrama abaixo mostra um cilindro suavizado e um facetado.

Quando condições de iluminação são aplicadas a um objeto facetado, as sombras resultarão em algo como:

Isso ocorre porque superfícies de triângulos são planas. Quando aplicamos a suavização, os cantos das faces, principalmente alguns daquelas que formas ângulos obtusos, o sombreamento ocorrerá de forma homogênea para aproximar quanto for possível a uma superficie curva.

compare abaixo os resultados: com um cilindro real e um cilindro suavizado.

Note que os cantos que formar um ângulo igual ou menor que noventa graus não são suavizados.

If possible, smoothing should only be applied to faces with angles of 60 degrees or less (to adjacent faces). You must be quite selective in which faces you choose to apply smoothing too.

A few more words need to be said about the problem that was hinted at earlier with regard to the cylinder.

There will be no problem (with angles) in smoothing the curved surface of the cylinder provided 6 or more edges around a circular end were used (12 triangular faces on the curved surface). However it is desired to retain the crease between the top surface and the side, and of course at the bottom as well.

To achieve this smoothing should be applied to the faces on the curved surface only.

For a cylinder such as the one shown below this can be done by selecting all the vertices that make up the cylinder and then setting smoothing to OFF. Then, by using the Selector (in a window which show the circular section), the vertices at the center of the top and bottom surfaces are selected. Finally by clicking on the Select Swap icon the appropriate vertices are selected. Smoothing is activated for faces in the Designer's Attributes dialog.

Quando deseja suavizar várias superficies que formam angulos proibidos separe a superfície desejada da outra criando um chanfro entre elas e então aplique a suavização.

Canto comum

Chanfro (Um canto para cada superfície)

Para aplicar a suavização a faces específicas, selecione-as somente elas.


Quick Render

Renderização rápida na vista câmera

Renderiza o conteúdo do Designer com mapeamentos, texturas, reflexões, etc. com anti-serrilhado médio. Ótimo pra previsualizar! F12 é o atalho do teclado para essa opção.

Dica: Renderização rápida é muito mais veloz se o monitor for definido para 16 milhões de cores.


Renderer Overview

Renderizador

Selecione as definições desejadas para a renderização no Controles, Opções, Definições, e Raytrace . Pressione o botão Render para iniciar o processo.

Por padrão é usado o renderizador por "Scanline". Vários níveis de Raytrace podem ser aplicados noPainel Raytrace, lembre-se que Raytrace consome mais memória do que Scanline.

Note Renderiazação de teste pode ser feita rapidamente com o comandoArquivo > Renderização rápida (F12) a partir do Animador ou do Designer.


Render Control Tab Page

Renderizador OpenFX

Resolução - Escolha a resolução. Vc pode escolher de uma das pré-definições ou digitar o número de "pixels" para a imagem.

Anti-serrilhado - Escolha essa opção para definir o nível do anti-serrilhado. Basicamente anti-serrilhado suaviza o contornos dos objetos na renderização de forma a disfarçar os "pixels". Quanto maior o nível, maior o tempo de renderização.

Acelerar o Anti-serrilhado - Pode provocar resultados insatisfatórios. Experimente, se o resultado for bom para a imagem que vc está usando ele pode diminuir consideravelmente o tempo de renderização.

Misturar cores - Escolha o tipo de mistura que na verdade é otimização da paleta da imagem, imagens de 24 bit não precisam de mistura. Já imagens de 256 cores sim, essa é uma forma de evitar o "Banding" (cores num degradê quebradas por exemplo).

Há vários métodos de mistura. O "Floyd-Steinberg" é mais apropriado para imagens estáticas. "Noise Dithering" é mais apropriado para animação.

Formato da imagem - Selecione o formato. Isso irá determinar a paleta de cores automaticamente. GIF usa um formato de 8bits, TGA e TIF 16 bit ou 24 bit.

Tipo da animação - Selecione o formato.FLIC (256cores), AVI (padrão Windows), ou GIF animado (256cores). Note que arquivos FLC não possuem compressão se a resolução for maior que 640x480 "pixels".

Nome da imagem - Nome da imagem e pasta onde será gravada. Pasta padrão é "Render".

Nome da animação- Nome da animação e pasta onde será gravada. Pasta padrão é "Movies".

Quadro atual - Especifica qual quadro da animação será renderizado.

Alcance - Especifica um número de quadros que será renderizado.


Render Options Tab Page

Opções do Renderizador

Linha oculta - Renderiza a imagem desconsiderando as faces e arestas atrás dos modelos. Acelera a renderização.

Reflexo do solo com anti-serrilhado - Para reflexões do solo sem Raytrace.

Sem suavização - Desconsidera a suavização das faces e renderiza todos os cantos. Acelera a renderização e é possivel que ocorra desativação de algum mapeamento.

Reduzir Saturação - Pós-processo que remove cores 'ilegais' para o formato NTSC.

Escrever GIFs entrelaçado - Grava os GIFs no modo entrelaçado. O formato será o GIF 87.

Solo no canal alpha - Cria um alpha com o solo na imagem.

Escrever arquivo alpha separadamente - Escreve um arquivo alpha para cada imagem. Solo não está incluido.

Use armazenamento da tela cheia - Renderiza todos os "pixels" para um "buffer" de memória antes de cria o arquivo temporário. Ele aumenta a velocidade do Renderizador e imagens de Pós-processo requerem isso. Por outro lado exige um número alto de memória RAM.

Armazenamento Z - Cria um "buffer" com informação da profundidade da imagem. Use-o se a animação usa um pós-processo como neblina que requer essa opção ligada.

Usar armazenamento do ID do ator - Cria um "buffer" para o processo externo que identifica qual ator está visível na imagem final.

Exibir imagem enquanto renderiza


Render Settings Tab Page

Definições do renderizador

Velocidade da animação - Define a velocidae para arquivos FLI/FLC. O Valor é em unidade "jiffies", zero faz a animação rodar o mais rápido possível.

Ângulo da suavização

Luz ambiente % - Substitui a luz ambiente especificada no ator Atmosfera. Um máximo de 30% trabalha bem, valore maiores que 70% produz imagens com alto contraste.

Densidade da sombra % - Especifica a escuridão das sombras lançadas no solo. Define a densidade da sombra. 50% é o padrão, 100% produz sombras completamente negras, 0% não aparece sombra.

Armazenamento da Luz Spot - Altera a resolução das sombras lançadas pela luz. As sombras lançadas exigem memória. Um valor de zero impica que a luz não lança sombras. Vc pode calcular definições para resultados melhores multiplicando o número de "pixels" por 4 (isto é 320x200x4=256,000 bytes requiridos).

Ângulo da linha de ilustração -Ângulo máximo para as faces planas no modo Ilustração. Se duas faces são adjacentes e o angulo entre elas é menor que este valor o contorno não será desenhado. Um alto valor resultará em apenas um contorno no modelo na imagem, que pode ser útil para imitar o estilo "Cartoons" para desenho animado.

Valor do Ruído - Granula a imagem.

Desfoque de movimento - Valores altos geram desfoque de movimento. O alcance normal é 0-10. Quando um número fora desse alcance é definido a integração do desfoque inicia.

Dígitos nos nomes dos arquivos - Especifica o número do quadro no nome do arquivo renderizado.

Qualidade da imagem JPEG - Especifica a qualidade da compressão JPEG. Qualidade alta cria arquivos de grandes tamanhos.

Especificar números de processadores - Ativa seleção de 1-16 processadores ou coloca o renderizador automaticamente para determinar o número de processadores e atribuir a cada um trabalho.

Definições pessoais - Gravar e ler definições personalizadas.


Render Trace Tab Page

Raytrace

Opções para renderização utilizando Raytrace.

Traçar sombras - Todas as sombras são automaticamente calculadas.

Traçar reflexões - Todas as superfícies reflectivas autmoticamente são calculadas.

Traçar refração - Todas as superfícies com refração autmoticamente são calculadas.


Tutorials Index

Tutoriais

Visite www.br.openfx.org para acessar vários tutorias, e a medida que o tempo for passando novos serão ali acrescentados.


3D Cursor

Cursor 3D

O Cursor 3D é usado para indicar uma posição exata no espaço 3D. Ele é posicionado nas vistas Superior, Anterior e laterais através do cursor do mouse (clicando numa área)

O Cursor 3D pode ser mostrado como uma cruz ou um alvo. Vc pode alternar usando a tecla F9.

Cursor 3D em cruz

3D Cursor 3D em alvo


3D Plot Tool

Ferramenta Lápis

Ela cria em 3D vétices e Arestas no espaço dentro da janela da vista.

Os vértices são criados na posição do Curso 3D e conecta-se ao próximo vértice criado.

Mova o cursor 3D próximo do lugar onde vc deseja iniciar a curva. A curva pode iniciar-se num vértice previamente selecionado sendo assim soldada ao mesmo, faça isso posicionando o cursor 3D próximo do vértice selecionado. Mantenha o botão esquerdo pressionado e clique o direito para soldar ao vértice ou para criar um novo vértice numa posição onde não existe um vértice, arraste então para a posição desejada do próximo vértice criando assim uma aresta até o primeiro. Caso for clicado em cima de um vértice selecionado a aresta será soldado a ele. Se as arestas ao redor formarem um triângulo então uma face será definida no local. Use CTRL para desabilitar a soldagem automática.

Enquanto defini uma curva 3D, vc pode mover entre as três vistas da área de trabalho do Designer, posicionando assim os vértices em qualquer eixo do espaço 3D


Closed Path

Caminho fechado

Um caminho fechado tem loops e precisa ter no mínimo três nós.

Caminho fechado


Costume Channel

Linha do tempo avatar

Ela determina a aparência do Ator, i.e, qual avatar o ator usará.

Nota: Um ator pode existir sem um avatar, mas ele será invisível. Este é um caminho para fazer atores desaparecerem durante a animação, simplesmente apague a linha do tempo avatar nos quadros apropriados.

Exceto os atores Câmera e Alvo, que não possuem avatar, as definições são agrupadas na caixa de diálogo que aparecerá quando um linha do tempo é criada. Essa caixa mostra a extensão da linha do tempo, e outras configurações dependendo do tipo de ator.

Duplo clique no Q-chave no indicador no fim de uma linha do tempo do avatar exibe uma caixa de diálogo com botões apagar, cortar, copiar e editar.

Editar - Altera as definições dependendo do tipo de ator.

Cancelar - Sai da caixa de diálogo.

Apagar - Apaga a linha do tempo removendo-a do Q-chave.

Cortar - Corta um avatar da linha do tempo.

Copiar - Copia uma avatar e sua linha do tempo com as mesmas definições.


Fill Outline

Fills single or multiple closed curves with edges and faces to make the outline solid and visible when rendered.

The curves must lie in the same plane and must not intersect or be looped. If one curve lies inside another it will result in a hole in the outline as in the internal hollow of the letter

Unfilled Outline

Filled Outline


Fill to Cursor

Preencher no cursor

Cria faces para preencher o espaço envolvido por vértices selecionados. Um vértice extra é colocado na posição do Cursor3D . O vértice extra é unido aos outros vértices por arestas. Onde os vértices formares faces, elas serão adicionadas.

Esta função é muito útil para preencher contornos convexos.

Contorno vazio

Preencher no cursor com o Cursor3D no mesmo plano do contorno

Preencher no cursor com o Cursor3D acima do plano do contorno.


Image Processor Effect Types

Tipos de efeito de pós-processo

Insere um efeito a partir da caixa de diálogo abaixo.

Desfoque - Desfoca a tela para simular movimento.

Profundidade de campo - Simula efeito fotográfico de desfocar o fundo e focar o objetivo.

Filtro - Altera a cor dos "pixels" de acordo com o parâmetro desejado após a renderização.

Reflexo de lente - Simula o efeito das luzes refletindo nas lentes de uma câmera.

Neblina - Simula neblinas e nevoeiros.

Aura - Adiciona uma aura na cor desejada.

Auréola - Adiciona uma auréola em volta das luzes.

Brilho - Adiciona um brilho para as luzes.

Laser - Simula um raio laser.

Campo estelar - Gera um campo estelar (móvel).

Estrelas - Cria o efeito de estrelas na animação (fixo).

Supernova - Simula o efeito de uma estrela em supernova.

Trilhas - Deixa uma trilha atrás de modelos em movimento na animação.

Video - Oferece 24 tipos de efeitos de vídeo.

Xvideo - 26 efeitos de vídeos adicionais.

Veja sobre adicionais pós-processos especiais.

Bola de fogo..

Luz volumétrica...


Internal Rotation Types

Tipos de Rotação interna

Há alguns tipos especiais de rotações que são difíceis de fazer manualmente. Os botões na caixa de rotação interna possibilitam uma rápida forma de especificar movimentos internos, isto é, relativo ao Ator. Um exemplo disso é as lâminas do rotor de um helicóptero. A direção do ator é especificada nos quadros chaves, enquanto que a rotação interna é determinada por esses controladores.

Nenhum - nenhuma rotação interna.

Eixo vertical - Ator rotacionado internamente através do eixo vértical (Z na vista superior) do centro do ator.

Eixo lateral - Ator é rotacionado internamente através do seu eixo lateral (X na vista lateral).

Eixo Frontal - Ator é rotacionado internamente através do seu eixo frontal (Y na vista Anterior).

Sentido horário - Ator é rotacionado na direção no eixo especificado vertical, lateral ou frontal.

Sentido anti-horário - Ator é rotacionado na direção no eixo especificado vertical, lateral ou frontal.


Keyframer Layout

Layout do Q-chave

Na janela do Q-chaves, o tempo caminha horizontalmente da esquerda para a direita. Cada ator possue quatro linhas do tempo Avatar, Posição (Movimento), Rotação, Tamanho (eescala), de cima para baixo. São representados nas cores azul, amarelo, verde, vermelho respectivamente.

Os quadros chaves são pontos quadros em suas respectivas linhas e cores. No modo Janela possui um simples menu Editar onde os atores podem ser modificados, a barra de status mostra o alcance dos quadros e o quadro indicado (no canto inferior direito). Os quadros-chaves podem ser arrastados com o mouse e normalmente são criados quando vc altera alguma característica no Animador para a cena.


Loaded Path

Ler caminho

Abre um caminho que foi gravado como um arquivo .PTH, criado no designer anteriormente.

Alguns exemplos de caminhos gravados: Circular.pth, Elliptic.pth, Helix.pth, Parabola.pth, and Spiral.pth.


Modeler WindowBox

Designer Working-Volume

The Designer Working-Volume is a cubic volume of space which is used as the working environment for building models and assigning attributes. It can be moved around and changed in size so that detailed movements can be made on a small scale.

The Working-Volume views show what's inside it:

TOP | Top looking down
FRONT | Front looking back
SIDE | Right side looking left

The Camera View (view at upper right corner) is a 3D rendering of the Model displayed in the Working-Volume.


Movement Channel

Linha do tempo posição

A linha do tempo posição no Q-chave controla onde e como um modelo irá mover entre quadros-chaves.

Todas as definições estão numa única caixa de diálogo. Ela mostra a extensão da linha do tempo, as coordenadas e o Tipo de movimento.

Apagar - apaga a linha do tempo.

Cortar - apaga a linha do tempo atual e retorna todas as posições anteriores.

Copiar - copia as características do movimento para outro ator.


Movement Types

Tipos de movimentos

Há 6 tipos de movimentos para um Ator.

Interpolar - A posição do Ator é interpolada linearmente entre o primeiro quadro-chave e os subsequentes. Por exemplo, se o ator possuir um movimento nos quadros 1-1 e 2-10 e ele está nas coordenadas 0,0,0 no quadro 1 e nas coordenadas 10,10,10 no quadro 10 então no quadro 5 ele estará na coordenada 5,5,0.

Curva natural- A posição do ator é interpolada numa curva ancorada nos quadros-chaves removendo o efeito de cantos agudos. Provendo assim um movimento mais natural com aceleração e desaceleração suaves.

Os próximos tipos requerem que um ator persiga outro. Clique no botão Seguir para definir o ator que será seguido.

Seguir - O ator irá seguir outro ator num caminho. Dica: faça uma luz seguir a câmera. Isso irá dar uma boa iluminação aos atores visíveis.

Seguir com balanço - O Balanço é definido no modelo que o ator está usando como avatar. O balanço é indicado para cruz vermelha no modelo visível no Designer (ponto perseguidor).

Seguir no caminho - segue um ator num caminho considerando seu balanço. Por exemplo, uma locomotiva segue um caminho, o primeiro vagão segue a locomotiva e assim sucessivamente.

Seguir amarrado- Segue um ator amarrado em um dos eixos de coordenadas. As outras coordenadas está livres para mover.


Open Path

Caminho aberto

Um caminho aberto possui pontos iniciais e finais distintos. Precisa ter pelo menos dois nós.

Open Path

Note que Nó/ferramenta Vértex pode ser usada para modificar a forma e números de pontos no caminho.


Path Velocity Curve

Velocidade da curva

Permite vc controlar a velocidade e direção de Ator num Caminho.


Pen Tool

Draw Tool

This tool plots a curve (composed of a set of vertices and edges ) in the Working-Volume view windows.

Place the first vertex of the curve by clicking once in one of the Working-Volume view windows. Click and drag the 3D Cursor (a rubber band line is drawn between the last vertex inserted and the 3D Cursor while the left mouse button is held down) to the desired position of the next vertex of the curve. Release the left mouse button to create the next vertex of the curve. If you just click the left mouse button, a vertex is added at that point.

If the "Shift" key is held down while dragging the mouse then the extending line is constrained to 45° angles. The active window will scroll as the mouse approaches the edge of the window.

If the "Ctrl key" is held down then no new vertices are created. This enables positioning of the 3D Cursor in two windows before re-commencing drawing.

If the "Alt" key is held down then when the mouse is clicked a "New edge" is started. The "New edge" is not attached to any previous vertex on the curve.

The DrawTool can also be used to draw edges between existing vertices by clicking exactly on top of the desired vertex.

To enable the 3D Plot Tool , double-click on the DrawTool.

See also:
Face and Edge Creation
Strutting and Faceting


Quick Render

Renderização rápida

Clique direito na vista Câmera e escolher Renderização rápida ou usar F12. A renderização mostrará, mapeamento, texturas, reflexos, etc.

Note que a opção no menu não estará disponível se o recurso Sombreamento via OpenGL estive ligado.

Dica: Renderização rápida será mais rápida se o monitor estiver no modo 16 milhoões de cores.


Renderer

The Renderer is the module that creates the photographic images of models built in the Designer and the animated sequence of images as directed in the Animator .

Rendering is quite a time consuming process and the time it takes is very dependent on the size image being produced and the complexity of the Actor's costumes.

The Renderer module can be used in a mode (called the Script Renderer) that does not need either the Animator or Designer modules to be loaded. The Script Renderer may also be run on several others PCs at the same time.

See:

  • Renderer Overview
  • Render Control Tab Page
  • Render Options Tab Page
  • Render Settings Tab Page
  • Render Trace Tab Page


Rotation Channel

Linha do tempo rotação

É a linha verde no Q-chave e controla a rotação de um Ator de acordo com os quadros-chaves.

A caixa de diálogo mostra a extensão da linha do tempo, o alinhamento em graus nos 3 eixos do ator, e o tipo de rotação.

Apagar - apaga a linha do tempo rotação.

Cortar - apaga a linha do tempo corrente.

Copiar - copia as características de rotação para outro ator.


Rotation Types

Tipos de rotação

Interpolar - A rotação do ator é interpolado entre o primeiro quadro-chave e o último. Em outras palavras, marque os quadros-chaves e o programa se encarregará de calcular o intervalo.

Interpolação suave - Cria uma rotação mais natural com aceleração e desaceleração.

Os próximos tipos necessitam que o ator esteja alinhado, acompanhando, imitando a rotação de outro ator.

Alinhar no caminho - Se um ator está seguindo um caminho, então defina sua rotação no caminho.

Acompanhar - O ator é forçado a acompanhar um outro ator.

Imitar - Dá a este ator o mesmo alinhamento do ator alvo.

Rotação interna - Há alguns tipos especiais de rotações que são difíceis de fazer manualmente. Os botões na caixa de rotação interna possibilitam uma rápida forma de especificar movimentos internos, isto é, relativo ao Ator. Um exemplo disso é as lâminas do rotor de um helicóptero. A direção do ator é especificada nos quadros chaves, enquanto que a rotação interna é determinada por esses controladores.


Scale Channel

Scale TImeline

The Scale Timeline is the fourth timeline (red colored horizontal bar) in the Keyframer and controls how an Actor will change size from keyframe to keyframe.

The scale of the Actor is interpolated between the keyframes in the timeline. If there is no additional keyframe, the scale from the single keyframe applies to all frames.

All settings are grouped in a single dialog which will appear when a timeline is created or edited. The dialog shows the timeline extent and the scale in three axes of the Actor in current units.

Bouncy - Scale values interpolate using either a linear or quadratic rule with on being quadratic. The quadratic method can give a smoother looking effect, but in some cases it can get quite bouncy.

The Delete button deletes the timeline.

The Reset button sets all scale values to unity.

The Store button copies the scale values to a temporary buffer for use later.

The Set button sets the scale values those previously stored.

The Copy button copies the scale characteristics of another Actor.


Vertex_Selector_Tool

Selecionador de vértices

Seleciona e move um vertice. Seleciona nós de um esqueleto e pivôs em volta do nó selecionado.

Clicando longe de um vértice e arrastando cria uma área de seleção. E essa área pode ser alterada conforme a lista abaixo.

Modificador | Ação resultante
Nenhum | Seleção retangular
Alt | Deseleção retangular
Shift | Seleção laço
Shift + Alt | Deseleção laço
Ctrl | Seleção circular
Ctrl + Alt | Deseleção circular


Postprocessor Atmospherics

Pós-processo Luz-Volumétrica

Cria um efeito volumétrico no cone da luz spot. Ele é controlado através da caixa de diáloga abaixo

Aviso: calcular esse efeito é muito demorado, portanto escolha cuidadosamente as opções aqui

SFXplugAtmosXX1.GIF (45198 bytes)

A primeira coisa a considerar é que há dois tipos de efeitos atmosféricos cobertos na caixa de diálogo:

  1. Uma simulação detalhada do efeito volumétrico envolvendo um tempo de calculo alto e ajustes finos nos parâmetros que requerem experimentação para que vc consiga o resultado desejado, esses parâmetros são Amostras, Neblina superdensa, Sombra extra-forte e Atenuação máxima.
  2. O segundo tipo é uma aproximação instantânea que não envolve muito detalhamento e cálculos. Para usá-los habilite a caixa Usar efeitos atmosféricos e escolha o tipo de efeito (As outras opções não afetarão esses efeitos).

Os efeitos trabalham em conexão com as luzes do tipo Spot, vc pode especificar qual luz será afetada pelo efeito.

Tipo de efeitos volumétricos
Vamos comparar os efeitos com uma simples luz spot sobre um objeto como representado abaixo:

SFXplugAtmosXX3.gif (13723 bytes)

Agora vamos adicionar o efeito chamado "Raios de luz" que apresentará um resultado semelhante a este: (lembre-se de ticar a caixa de efeitos volumétricos)

SFXplugAtmosXX4.gif (17132 bytes)

Esse tipo de luz representaria bem uma atmosfera num dia frio com as luzes entre as árvores ou imagens subaquáticas.

Agora vamos aplicar o efeito "Vento" :

SFXplugAtmosXX5.gif (17368 bytes)

E agora vamos tentar o "Poeira":

SFXplugAtmosXX6.gif (25039 bytes)

Por fim o efeito "Fumaça" :

SFXplugAtmosXX7.gif (17330 bytes)

'Integração total da luz volumétrica'

Para obter um tipo de luz volumétrica super real teremos que usar o Raytrace. Claro que usando esse recurso o tempo de renderização aumentará consideravelmente. Quanto maior o número de amostras maior o tempo do Render.

Outro controle é a aparencia da neblina. Basicamente são Neblina superdensa e Sombra extra-forte.

Para vermos como as amostras trabalham, analisemos os exemplos abaixo:

Uma luz sem efeito aplicado:

SFXplugAtmosXXfull0.gif (8305 bytes)

Renderizando com 32 amostras e os valores para: (Neblina superdensa)=0.0 (Sombra extra-forte)=0.0 (Atenuação Máx.) temos:

SFXplugAtmosXXfull1.gif (17293 bytes)

Reduzindo o valor da Atenuação máxima para 0.25 reduz a densidade da neblina assim:

SFXplugAtmosXX9.gif (15670 bytes)

Usando (Sombra extra-forter)=1.0 teremos: (Para um cena mais natural o valor apropriado é 0.0:

SFXplugAtmosXXfull2.gif (17729 bytes)

Por fim usando (Neblina superdensa)=1.5

SFXplugAtmosXXfull3.gif (12077 bytes)

Veja esses outros exemplos:

No exemplo abaixo 16 amostras são usadas com Neblina superdensa a 3.0:

SFXplugAtmosXXex1.gif (32682 bytes)

SFXplugAtmosXXex2.gif (31154 bytes) SFXplugAtmosXXex3.gif (31471 bytes)

No exemplo abaixo (atmos_full_ex3.stg) um pós-processo neblina é combinado com a luz volumétrica. Note que vc pode ver a luz atravessar por um dos buracos do objeto (a partir do quadro 3) o rastro é renderizado na cor da neblina.

No último exemplo (Atmos_full_ex4.stg) um intenso efeito de luz atravessa um objeto com valores de Neblina superdensa 1.0 reduzindo para uma atenuação máxima de 0.5.

SFXplugAtmosXXex4.gif (47471 bytes) SFXplugAtmosXXex5.gif (32447 bytes)

Comentários:

  1. Quanto mais áreas da tela forem cobertas com a luz volumétrica mais demorado será a renderização. Veja no exemplo abaixo que a luz está um pouca abaixo da aeronave vindo em direção a câmera o que levará a um tempo muito grande de renderização:
    SFXplugAtmosXXA.gif (38398 bytes)
  2. Faça experimentos usando resoluções mais baixas. Veja os exemplos que acompanham o progama.
  3. A extensão de luz volumétrica ésta na subpasta Postprocess sob os nomes ATMOS.XFX e ATMOS.DLL.
  4. Os 'Efeitos volumétricos' são mais velozes, use-os sempre quando for apropriado.


Post Processor FireballPlugin

Bola de Fogo

Essa extensão gera bolas de fogo fractais e explosões.

Como essa extensão trabalho com elementos animados, é melhor usada como um ator de efeito (FX).

Essa extensão é controlada pela caixa de diálogo abaixo:

fireball1.gif (47745 bytes)

Igual aos efeitos Auréola e Reflexos de lentes a Bola de Fogo é amarrada a uma luz. Ela pode ser amarrada a uma luz normal associando-a com um cubo limitado. Agora éssa é a restrição principal:

A luz onde está amarrada a bola de fogo precisa ter sua origem atenuada

Se vc tentar usar uma Bola de fogo com uma luz não atenuada éla não funcionará. A razão de usar uma luz com atenuação é para indicar ao Animador que a esfera que define a atenuação define a intensidade da bola de fogo ou explosão. O efeito usa essa esfera como um container para confinar a bola de fogo no seu interior.

Veja um exemplo do resultado espetacular desse efeito!

XFXfireball2ps.jpg (7203 bytes)

Clique aqui para ver uma imagem maior

Controlando o efeito:

  • Chamas
    Quando esse botão estiver ticado a aparência será como a imagem da direita.
    temp.gif (12904 bytes) temp1.gif (21608 bytes)
  • Explosão
    A explosão irá gerar bolas de fogo que irão aparecer e dispersar em fumaça no final da animação.

Definições da luz
O efeito pode ser aplicado a todas as luzes na cena ou a uma luz especificada.

Cores
Existe 3 definições. A escuridão é usada para a cor da fumaça, a do centro para o coração da bola de fogo e a externa para as extremidades da chama.

Suavização da granulação
Veja no esquema abaixo o que a suavização pode fazer. Coloque os valores na caixa para o efeito desejado.

temp.gif (48513 bytes)

Densidade
Use para definir o brilho, veja a ilustração para ver o que certos valores podem causar.

temp.gif (35054 bytes)

Regularidade
A regularidade (Padrão 0.2) determina como a explosão vai aparecer. Um valor de 2.0 é próximo a uma perfeita esfera (ou uma estrela)

temp.gif (33016 bytes)

Alcance vertical
Use em conjunto com uma chama para simular uma fogueira, por exemplo. A imagem abaixo usa um valor de 3.

temp2.gif (8497 bytes)

Expansão
Quando este valor é o padrão então o tamanho da esfera envolverá a bola de fogo. Se vc deseja que a bola de fogo ocupe um espaço maior ou menor, altere esse valo.

Amostras
Controlam a qualidade da integração fractal, um valor alto aplica mais detalhes na bola de fogo, mas aumenta o tempo de cálculo. Um valor abaixo de 4 pode dar uma boa aparência a bola de fogo.